[Spice-devel,[PATCH,spice-common] 1/2] Update glib requirements to 2.38

Submitted by Eduardo Lima (Etrunko) on March 28, 2016, 9 p.m.

Details

Message ID 1459198828-7986-2-git-send-email-etrunko@redhat.com
State New
Headers show
Series "2/2] Add check for openssl" ( rev: 1 ) in Spice

Not browsing as part of any series.

Commit Message

Eduardo Lima (Etrunko) March 28, 2016, 9 p.m.
From: "Eduardo Lima (Etrunko)" <etrunko@redhat.com>

Recent logging tests make use of g_test_subprocess() and
g_test_trap_subprocess() functions, available only in glib newer than
2.38.

Signed-off-by: Eduardo Lima (Etrunko) <etrunko@redhat.com>
---
 configure.ac     | 2 +-
 m4/spice-deps.m4 | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

Patch hide | download patch | download mbox

diff --git a/configure.ac b/configure.ac
index 2ff985d..bfdf869 100644
--- a/configure.ac
+++ b/configure.ac
@@ -35,7 +35,7 @@  SPICE_CHECK_PYTHON_MODULES()
 SPICE_CHECK_PIXMAN
 SPICE_CHECK_SMARTCARD
 SPICE_CHECK_CELT051
-SPICE_CHECK_GLIB2
+SPICE_CHECK_GLIB2(2.38)
 SPICE_CHECK_OPUS
 SPICE_CHECK_OPENGL
 
diff --git a/m4/spice-deps.m4 b/m4/spice-deps.m4
index 88edf7e..ecae80a 100644
--- a/m4/spice-deps.m4
+++ b/m4/spice-deps.m4
@@ -173,7 +173,7 @@  AC_DEFUN([SPICE_CHECK_PIXMAN], [
 # use in the GLIB2_CFLAGS and GLIB2_LIBS variables.
 #------------------
 AC_DEFUN([SPICE_CHECK_GLIB2], [
-    PKG_CHECK_MODULES(GLIB2, glib-2.0 >= 2.22 gio-2.0 >= 2.22)
+    PKG_CHECK_MODULES(GLIB2, glib-2.0 >= $1 gio-2.0 >= $1)
 ])
 
 # SPICE_CHECK_PYTHON_MODULES()

Comments

Hey,

On Mon, Mar 28, 2016 at 06:00:27PM -0300, Eduardo Lima (Etrunko) wrote:
> From: "Eduardo Lima (Etrunko)" <etrunko@redhat.com>
> 
> Recent logging tests make use of g_test_subprocess() and
> g_test_trap_subprocess() functions, available only in glib newer than
> 2.38.

glib 2.38 is far too new to be used as the global required version for
spice and spice-gtk. We should disable these tests when a too old glib
is used.

Christophe

> 
> Signed-off-by: Eduardo Lima (Etrunko) <etrunko@redhat.com>
> ---
>  configure.ac     | 2 +-
>  m4/spice-deps.m4 | 2 +-
>  2 files changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/configure.ac b/configure.ac
> index 2ff985d..bfdf869 100644
> --- a/configure.ac
> +++ b/configure.ac
> @@ -35,7 +35,7 @@ SPICE_CHECK_PYTHON_MODULES()
>  SPICE_CHECK_PIXMAN
>  SPICE_CHECK_SMARTCARD
>  SPICE_CHECK_CELT051
> -SPICE_CHECK_GLIB2
> +SPICE_CHECK_GLIB2(2.38)
>  SPICE_CHECK_OPUS
>  SPICE_CHECK_OPENGL
>  
> diff --git a/m4/spice-deps.m4 b/m4/spice-deps.m4
> index 88edf7e..ecae80a 100644
> --- a/m4/spice-deps.m4
> +++ b/m4/spice-deps.m4
> @@ -173,7 +173,7 @@ AC_DEFUN([SPICE_CHECK_PIXMAN], [
>  # use in the GLIB2_CFLAGS and GLIB2_LIBS variables.
>  #------------------
>  AC_DEFUN([SPICE_CHECK_GLIB2], [
> -    PKG_CHECK_MODULES(GLIB2, glib-2.0 >= 2.22 gio-2.0 >= 2.22)
> +    PKG_CHECK_MODULES(GLIB2, glib-2.0 >= $1 gio-2.0 >= $1)
>  ])
>  
>  # SPICE_CHECK_PYTHON_MODULES()
> -- 
> 1.8.3.1
> 
> _______________________________________________
> Spice-devel mailing list
> Spice-devel@lists.freedesktop.org
> https://lists.freedesktop.org/mailman/listinfo/spice-devel
On 03/29/2016 05:18 AM, Christophe Fergeau wrote:
> Hey,
> 
> On Mon, Mar 28, 2016 at 06:00:27PM -0300, Eduardo Lima (Etrunko) wrote:
>> From: "Eduardo Lima (Etrunko)" <etrunko@redhat.com>
>>
>> Recent logging tests make use of g_test_subprocess() and
>> g_test_trap_subprocess() functions, available only in glib newer than
>> 2.38.
> 
> glib 2.38 is far too new to be used as the global required version for
> spice and spice-gtk. We should disable these tests when a too old glib
> is used.

Well, at least for spice-gtk there is a requirement for recent Gtk+
version, which I _think_ may force a newer glib version as well. Also,
for virt-viewer we already require 2.38.

Anyway, I can add the --disable-tests flag if you think it is a better
solution.
On Tue, Mar 29, 2016 at 09:26:49AM -0300, Eduardo Lima (Etrunko) wrote:
> On 03/29/2016 05:18 AM, Christophe Fergeau wrote:
> > Hey,
> > 
> > On Mon, Mar 28, 2016 at 06:00:27PM -0300, Eduardo Lima (Etrunko) wrote:
> >> From: "Eduardo Lima (Etrunko)" <etrunko@redhat.com>
> >>
> >> Recent logging tests make use of g_test_subprocess() and
> >> g_test_trap_subprocess() functions, available only in glib newer than
> >> 2.38.
> > 
> > glib 2.38 is far too new to be used as the global required version for
> > spice and spice-gtk. We should disable these tests when a too old glib
> > is used.
> 
> Well, at least for spice-gtk there is a requirement for recent Gtk+
> version, which I _think_ may force a newer glib version as well. Also,
> for virt-viewer we already require 2.38.

spice(-server) uses the spice-common submodule and only requires glib
2.22.

> 
> Anyway, I can add the --disable-tests flag if you think it is a better
> solution.

--disable-tests would work, but I had in mind something more automatic:
dnl <insert glib 2.38 detection here>
AM_CONDITIONAL(HAVE_GLIB_2_38, [test "x$have_glib_2_38" == "xyes"])

and then only build the tests needing a newer glib if this conditional
was set.

Christophe