[Spice-devel] Bump minimum required glib2 version to 2.26

Submitted by Andrea Spadaccini on Sept. 7, 2011, 9:58 p.m.

Details

Message ID 1315407504-22306-1-git-send-email-spadaccio@google.com
State New, archived
Headers show

Not browsing as part of any series.

Commit Message

Andrea Spadaccini Sept. 7, 2011, 9:58 p.m.
spice-gtk code uses the G_DEFINE_BOXED_TYPE macro, that is defined in
glib2 2.26, so configure should really check for this minimum version
instead of 2.22.

Signed-off-by: Andrea Spadaccini <spadaccio@google.com>
---
 configure.ac |    2 +-
 1 files changed, 1 insertions(+), 1 deletions(-)

--
1.7.3.1

Patch hide | download patch | download mbox

diff --git a/configure.ac b/configure.ac
index 98b91de..8da2dcc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -220,7 +220,7 @@  else
         EXTERNAL_PNP_IDS="$with_pnp_ids_path"
 fi

-PKG_CHECK_MODULES(GLIB2, glib-2.0 >= 2.22)
+PKG_CHECK_MODULES(GLIB2, glib-2.0 >= 2.26)
 AC_SUBST(GLIB2_CFLAGS)
 AC_SUBST(GLIB2_LIBS)


Comments

Hi

spice-gtk should compile with old version of glib.

In the past, I added the BOXED macros in gtk/display/gnome-rr.c

I suggest we move those macros into a gtk/glib-compat.h or something like that.

Feel free to provide a new patch. If not we will fix it soonish, ie before next release.

thanks!