[xf86-video-trident,v2,2/2] Rename trident_pci_rename.h to pci_rename.h

Submitted by Kevin Brace on May 11, 2019, 4:19 a.m.

Details

Message ID 20190511041928.6851-3-kevinbrace@gmx.com
State New
Headers show
Series "Rename tridentpcirename.h to pci_rename.h" ( rev: 1 ) in X.org

Not browsing as part of any series.

Commit Message

Kevin Brace May 11, 2019, 4:19 a.m.
PCI rename header file appears to be generic, so trident_ prefix
should be dropped.

Signed-off-by: Kevin Brace <kevinbrace@gmx.com>
---
 src/{trident_pci_rename.h => pci_rename.h} | 6 +++---
 src/trident.h                              | 2 +-
 2 files changed, 4 insertions(+), 4 deletions(-)
 rename src/{trident_pci_rename.h => pci_rename.h} (98%)

--
2.17.1

Patch hide | download patch | download mbox

diff --git a/src/trident_pci_rename.h b/src/pci_rename.h
similarity index 98%
rename from src/trident_pci_rename.h
rename to src/pci_rename.h
index 991273b..c8ebed7 100644
--- a/src/trident_pci_rename.h
+++ b/src/pci_rename.h
@@ -26,8 +26,8 @@ 
  * library. The main purpose being to facilitate source code compatibility.
  */

-#ifndef TRIDENT_PCI_RENAME_H
-#define TRIDENT_PCI_RENAME_H
+#ifndef PCI_RENAME_H
+#define PCI_RENAME_H

 enum region_type {
     REGION_MEM,
@@ -119,4 +119,4 @@  typedef struct pci_device *pciVideoPtr;

 #endif /* XSERVER_LIBPCIACCESS */

-#endif /* TRIDENT_PCI_RENAME_H */
+#endif /* PCI_RENAME_H */
diff --git a/src/trident.h b/src/trident.h
index 6f2ddc5..5cadf52 100644
--- a/src/trident.h
+++ b/src/trident.h
@@ -30,7 +30,7 @@ 
 #include <string.h>
 #include <math.h>

-#include "trident_pci_rename.h"
+#include "pci_rename.h"

 #include "exa.h"
 #include "xf86Cursor.h"