[v1] configure/vulkan: linking issue of Vulkan

Submitted by Sergii Romantsov on Aug. 20, 2018, 11:53 a.m.

Details

Message ID 1534766034-6966-1-git-send-email-sergii.romantsov@globallogic.com
State New
Headers show
Series "configure/vulkan: linking issue of Vulkan" ( rev: 1 ) in Mesa

Not browsing as part of any series.

Commit Message

Sergii Romantsov Aug. 20, 2018, 11:53 a.m.
Installing of Vulkan on Ubuntu 16.04 fails during relinking.
Seems caught libtool-issue.
Library-dependicies GL_LIB_DEPS moved upper.

Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=107624
Signed-off-by: Sergii Romantsov <sergii.romantsov@globallogic.com>
---
 src/glx/Makefile.am | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Patch hide | download patch | download mbox

diff --git a/src/glx/Makefile.am b/src/glx/Makefile.am
index 8f9d80c..bb30a85 100644
--- a/src/glx/Makefile.am
+++ b/src/glx/Makefile.am
@@ -176,10 +176,10 @@  endif
 # against the system one.
 GL_LIBS = \
 	$(LIBDRM_LIBS) \
+	$(GL_LIB_DEPS) \
 	libglx.la \
 	$(top_builddir)/src/mapi/glapi/libglapi.la \
-	$(top_builddir)/src/mapi/shared-glapi/libglapi.la \
-	$(GL_LIB_DEPS)
+	$(top_builddir)/src/mapi/shared-glapi/libglapi.la
 
 GL_LDFLAGS = \
 	-no-undefined \