[1/4] README.md: Note that python 3.3.x+ is supported

Submitted by Dylan Baker on June 8, 2018, 4:15 p.m.

Details

Message ID 20180608161551.1995-1-dylan@pnwbakers.com
State New
Headers show
Series "Series without cover letter" ( rev: 1 ) in Piglit

Not browsing as part of any series.

Commit Message

Dylan Baker June 8, 2018, 4:15 p.m.
---
 README.md | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Patch hide | download patch | download mbox

diff --git a/README.md b/README.md
index 30d7a2b5f..2d7d95674 100644
--- a/README.md
+++ b/README.md
@@ -30,7 +30,7 @@  The original tests have been taken from
 
 First of all, you need to make sure that the following are installed:
 
-  - Python 2.7.x
+  - Python 2.7.x or 3.3.x+
   - Python Mako module
   - numpy (http://www.numpy.org)
   - six (https://pypi.python.org/pypi/six)

Comments

On 8 June 2018 at 12:15, Dylan Baker <dylan@pnwbakers.com> wrote:

> ---
>  README.md | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/README.md b/README.md
> index 30d7a2b5f..2d7d95674 100644
> --- a/README.md
> +++ b/README.md
> @@ -30,7 +30,7 @@ The original tests have been taken from
>
>  First of all, you need to make sure that the following are installed:
>
> -  - Python 2.7.x
> +  - Python 2.7.x or 3.3.x+
>

Clearer to say?:

-  - Python 2.7.x
+  - Python 2.7.x or >=3.4

As you know Python 3.3.x has reached end-of-life.

Whilst piglit's code may still works with 3.3, there are a number of
dependencies which no longer do - as seen in piglit's continuous
integration testing. I'll separately send a patch for that.


   - Python Mako module
>    - numpy (http://www.numpy.org)
>    - six (https://pypi.python.org/pypi/six)
> --
> 2.17.1
>
> _______________________________________________
> Piglit mailing list
> Piglit@lists.freedesktop.org
> https://lists.freedesktop.org/mailman/listinfo/piglit
>
Quoting Rhys Kidd (2018-06-09 12:37:48)
> On 8 June 2018 at 12:15, Dylan Baker <dylan@pnwbakers.com> wrote:
> 
>     ---
>      README.md | 2 +-
>      1 file changed, 1 insertion(+), 1 deletion(-)
> 
>     diff --git a/README.md b/README.md
>     index 30d7a2b5f..2d7d95674 100644
>     --- a/README.md
>     +++ b/README.md
>     @@ -30,7 +30,7 @@ The original tests have been taken from
> 
>      First of all, you need to make sure that the following are installed:
> 
>     -  - Python 2.7.x
>     +  - Python 2.7.x or 3.3.x+
> 
> 
> Clearer to say?:
> 
> -  - Python 2.7.x
> +  - Python 2.7.x or >=3.4
> 
> As you know Python 3.3.x has reached end-of-life.
> 
> Whilst piglit's code may still works with 3.3, there are a number of
> dependencies which no longer do - as seen in piglit's continuous integration
> testing. I'll separately send a patch for that.

Yeah, it has. On the other hand python 2.7 is positively ancient, and I don't
see us dropping support for it any time soon. I guess before we drop 3.3 support
lets make sure there's no one relying on 3.3.

Dylan

>        - Python Mako module
>        - numpy (http://www.numpy.org)
>        - six (https://pypi.python.org/pypi/six)
>     --
>     2.17.1
> 
>     _______________________________________________
>     Piglit mailing list
>     Piglit@lists.freedesktop.org
>     https://lists.freedesktop.org/mailman/listinfo/piglit
> 
>