[4/8] arb_blend_func_extended/output-location: require GLSL 1.50

Submitted by Marek Olšák on April 10, 2017, 9:01 p.m.

Details

Message ID 1491858103-16838-4-git-send-email-maraeo@gmail.com
State New
Headers show
Series "Series without cover letter" ( rev: 1 ) in Piglit

Not browsing as part of any series.

Commit Message

Marek Olšák April 10, 2017, 9:01 p.m.
From: Marek Olšák <marek.olsak@amd.com>

---
 tests/spec/arb_blend_func_extended/api/output-location.c | 1 +
 1 file changed, 1 insertion(+)

Patch hide | download patch | download mbox

diff --git a/tests/spec/arb_blend_func_extended/api/output-location.c b/tests/spec/arb_blend_func_extended/api/output-location.c
index 1fc9203..4d01818 100644
--- a/tests/spec/arb_blend_func_extended/api/output-location.c
+++ b/tests/spec/arb_blend_func_extended/api/output-location.c
@@ -82,20 +82,21 @@  piglit_display(void)
 }
 
 void piglit_init(int argc, char **argv)
 {
 	GLint max_dual_source;
 	GLuint prog;
 	char fs_text[256];
 
 
 #ifdef PIGLIT_USE_OPENGL
+	piglit_require_GLSL_version(150);
 	piglit_require_extension("GL_ARB_blend_func_extended");
 #else // PIGLIT_USE_OPENGLES3
 	piglit_require_extension("GL_EXT_blend_func_extended");
 #endif
 	glGetIntegerv(GL_MAX_DUAL_SOURCE_DRAW_BUFFERS, &max_dual_source);
 
 	if (max_dual_source < 1) {
 		fprintf(stderr,
 			"ARB_blend_func_extended requires "
 			"GL_MAX_DUAL_SOURCE_DRAW_BUFFERS >= 1. "

Comments

I'd just bump the core version required to 32 instead. Either way,

Reviewed-by: Ilia Mirkin <imirkin@alum.mit.edu>

On Mon, Apr 10, 2017 at 5:01 PM, Marek Olšák <maraeo@gmail.com> wrote:
> From: Marek Olšák <marek.olsak@amd.com>
>
> ---
>  tests/spec/arb_blend_func_extended/api/output-location.c | 1 +
>  1 file changed, 1 insertion(+)
>
> diff --git a/tests/spec/arb_blend_func_extended/api/output-location.c b/tests/spec/arb_blend_func_extended/api/output-location.c
> index 1fc9203..4d01818 100644
> --- a/tests/spec/arb_blend_func_extended/api/output-location.c
> +++ b/tests/spec/arb_blend_func_extended/api/output-location.c
> @@ -82,20 +82,21 @@ piglit_display(void)
>  }
>
>  void piglit_init(int argc, char **argv)
>  {
>         GLint max_dual_source;
>         GLuint prog;
>         char fs_text[256];
>
>
>  #ifdef PIGLIT_USE_OPENGL
> +       piglit_require_GLSL_version(150);
>         piglit_require_extension("GL_ARB_blend_func_extended");
>  #else // PIGLIT_USE_OPENGLES3
>         piglit_require_extension("GL_EXT_blend_func_extended");
>  #endif
>         glGetIntegerv(GL_MAX_DUAL_SOURCE_DRAW_BUFFERS, &max_dual_source);
>
>         if (max_dual_source < 1) {
>                 fprintf(stderr,
>                         "ARB_blend_func_extended requires "
>                         "GL_MAX_DUAL_SOURCE_DRAW_BUFFERS >= 1. "
> --
> 2.7.4
>
> _______________________________________________
> Piglit mailing list
> Piglit@lists.freedesktop.org
> https://lists.freedesktop.org/mailman/listinfo/piglit