[Spice-devel,client,v2,3/3] build-sys: Enable deprecation warnings instead of ignoring them entirely

Submitted by Francois Gouget on Dec. 1, 2016, 3:27 a.m.

Details

Message ID alpine.DEB.2.20.1612010420410.561@amboise
State New
Headers show
Series "Deprecation warning cleanup" ( rev: 10 9 8 ) in Spice

Not browsing as part of any series.

Commit Message

Francois Gouget Dec. 1, 2016, 3:27 a.m.
On Wed, 23 Nov 2016, Christophe Fergeau wrote:

> On Wed, Nov 23, 2016 at 07:09:28AM +0100, Francois Gouget wrote:
> > For Spice-gtk most deprecation issues come from changes outside Spice
> > (GLib) and thus should not be treated as errors to not break
> > compilation for users who have newer third-party libraries.
> > However they must be visible otherwise Spice developers will not be
> > aware of them and thus will not fix them before breakage happens.
> 
> Also iirc -DXXX_VERSION_MIN_REQUIRED=yyy need deprecation warnings to be
> functional

Hmmm, I applied the patch below and I'm getting errors with or without 
this patchset.



Btw, what's the status of this patchset?

Patch hide | download patch | download mbox

diff --git a/configure.ac b/configure.ac
index f3e7f8d..4661e9f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -136,7 +136,7 @@  AS_IF([test "x$with_gtk" != "xno"],
       [AS_IF([test "x$os_win32" = "xyes"],
              [PKG_CHECK_MODULES(GTK, gtk+-3.0 >= $GTK_REQUIRED)],
              [PKG_CHECK_MODULES(GTK, gtk+-3.0 >= $GTK_REQUIRED epoxy)])]
-      [GTK_CFLAGS="$GTK_CFLAGS -DGDK_VERSION_MIN_REQUIRED=$GTK_ENCODED_VERSION \
+      [GTK_CFLAGS="$GTK_CFLAGS -DGDK_VERSION_MIN_REQUIRED=4 \
                                -DGDK_VERSION_MAX_ALLOWED=$GTK_ENCODED_VERSION"])
 SPICE_GTK_REQUIRES="${SPICE_GTK_REQUIRES} gtk+-3.0 >= $GTK_REQUIRED"
 

Comments

On Thu, Dec 01, 2016 at 04:27:36AM +0100, Francois Gouget wrote:
> On Wed, 23 Nov 2016, Christophe Fergeau wrote:
> 
> > On Wed, Nov 23, 2016 at 07:09:28AM +0100, Francois Gouget wrote:
> > > For Spice-gtk most deprecation issues come from changes outside Spice
> > > (GLib) and thus should not be treated as errors to not break
> > > compilation for users who have newer third-party libraries.
> > > However they must be visible otherwise Spice developers will not be
> > > aware of them and thus will not fix them before breakage happens.
> > 
> > Also iirc -DXXX_VERSION_MIN_REQUIRED=yyy need deprecation warnings to be
> > functional
> 
> Hmmm, I applied the patch below and I'm getting errors with or without 
> this patchset.
> 
> diff --git a/configure.ac b/configure.ac
> index f3e7f8d..4661e9f 100644
> --- a/configure.ac
> +++ b/configure.ac
> @@ -136,7 +136,7 @@ AS_IF([test "x$with_gtk" != "xno"],
>        [AS_IF([test "x$os_win32" = "xyes"],
>               [PKG_CHECK_MODULES(GTK, gtk+-3.0 >= $GTK_REQUIRED)],
>               [PKG_CHECK_MODULES(GTK, gtk+-3.0 >= $GTK_REQUIRED epoxy)])]
> -      [GTK_CFLAGS="$GTK_CFLAGS -DGDK_VERSION_MIN_REQUIRED=$GTK_ENCODED_VERSION \
> +      [GTK_CFLAGS="$GTK_CFLAGS -DGDK_VERSION_MIN_REQUIRED=4 \
>                                 -DGDK_VERSION_MAX_ALLOWED=$GTK_ENCODED_VERSION"])
>  SPICE_GTK_REQUIRES="${SPICE_GTK_REQUIRES} gtk+-3.0 >= $GTK_REQUIRED"

Dunno, with your patch applied, I'm getting
channel-webdav.c:317:5: attention : ‘g_output_stream_write_all_finish’
is deprecated: Not available before 2.44 [-Wdeprecated-declarations]

so the warning implies it's related to deprecation warnings (and it is
good to iee it as before I think this was silent)

Christophe
On Thu, Dec 01, 2016 at 04:27:36AM +0100, Francois Gouget wrote:
>  
> 
> 
> Btw, what's the status of this patchset?

Fine with me, I'll add a closing G_END_DEPRECATION_xxx to the end of
spicy.c and push. This adds a few more warnings in various places, but
they can be fixed afterwards (though I think you had sent patches for
these too).

Christophe