Remove RADEON_HOST_DATA_SWAP_HDW case from RadeonCopySwap

Submitted by Jochen Rollwagen on Nov. 4, 2016, 8:23 a.m.

Details

Message ID 581C456D.7010707@t-online.de
State New
Headers show
Series "Remove RADEON_HOST_DATA_SWAP_HDW case from RadeonCopySwap" ( rev: 1 ) in AMD X.Org drivers

Not browsing as part of any series.

Commit Message

Jochen Rollwagen Nov. 4, 2016, 8:23 a.m.
From ba45efaafc3cf790c44b905d2f6272ef7830b403 Mon Sep 17 00:00:00 2001
From: Jochen Rollwagen <joro-2013@t-online.de>
Date: Fri, 4 Nov 2016 08:39:30 +0100
Subject: [PATCH] Remove RADEON_HOST_DATA_SWAP_HDW case from RadeonCopySwap

RadeonCopySwap is never called with swap=RADEON_HOST_DATA_SWAP_HDW. 
Remove the case from the switch for clarity.
---
  src/radeon_accel.c |   10 ----------
  1 file changed, 10 deletions(-)

          unsigned int *d = (unsigned int *)dst;

Patch hide | download patch | download mbox

From ba45efaafc3cf790c44b905d2f6272ef7830b403 Mon Sep 17 00:00:00 2001
From: Jochen Rollwagen <joro-2013@t-online.de>
Date: Fri, 4 Nov 2016 08:39:30 +0100
Subject: [PATCH] Remove RADEON_HOST_DATA_SWAP_HDW case from RadeonCopySwap

RadeonCopySwap is never called with swap=RADEON_HOST_DATA_SWAP_HDW. Remove the case from the switch for clarity.
---
 src/radeon_accel.c |   10 ----------
 1 file changed, 10 deletions(-)

diff --git a/src/radeon_accel.c b/src/radeon_accel.c
index 1def2a3..af2fc99 100644
--- a/src/radeon_accel.c
+++ b/src/radeon_accel.c
@@ -131,16 +131,6 @@  int radeon_cs_space_remaining(ScrnInfoPtr pScrn)
 void RADEONCopySwap(uint8_t *dst, uint8_t *src, unsigned int size, int swap)
 {
     switch(swap) {
-    case RADEON_HOST_DATA_SWAP_HDW:
-        {
-	    unsigned int *d = (unsigned int *)dst;
-	    unsigned int *s = (unsigned int *)src;
-	    unsigned int nwords = size >> 2;
-
-	    for (; nwords > 0; --nwords, ++d, ++s)
-		*d = ((*s & 0xffff) << 16) | ((*s >> 16) & 0xffff);
-	    return;
-        }
     case RADEON_HOST_DATA_SWAP_32BIT:
         {
 	    unsigned int *d = (unsigned int *)dst;
-- 
1.7.9.5


Comments

On 04/11/16 05:23 PM, Jochen Rollwagen wrote:
> From ba45efaafc3cf790c44b905d2f6272ef7830b403 Mon Sep 17 00:00:00 2001
> From: Jochen Rollwagen <joro-2013@t-online.de>
> Date: Fri, 4 Nov 2016 08:39:30 +0100
> Subject: [PATCH] Remove RADEON_HOST_DATA_SWAP_HDW case from RadeonCopySwap
> 
> RadeonCopySwap is never called with swap=RADEON_HOST_DATA_SWAP_HDW.
> Remove the case from the switch for clarity.
> ---
>  src/radeon_accel.c |   10 ----------
>  1 file changed, 10 deletions(-)
> 
> diff --git a/src/radeon_accel.c b/src/radeon_accel.c
> index 1def2a3..af2fc99 100644
> --- a/src/radeon_accel.c
> +++ b/src/radeon_accel.c
> @@ -131,16 +131,6 @@ int radeon_cs_space_remaining(ScrnInfoPtr pScrn)
>  void RADEONCopySwap(uint8_t *dst, uint8_t *src, unsigned int size, int
> swap)
>  {
>      switch(swap) {
> -    case RADEON_HOST_DATA_SWAP_HDW:
> -        {
> -        unsigned int *d = (unsigned int *)dst;
> -        unsigned int *s = (unsigned int *)src;
> -        unsigned int nwords = size >> 2;
> -
> -        for (; nwords > 0; --nwords, ++d, ++s)
> -        *d = ((*s & 0xffff) << 16) | ((*s >> 16) & 0xffff);
> -        return;
> -        }
>      case RADEON_HOST_DATA_SWAP_32BIT:
>          {
>          unsigned int *d = (unsigned int *)dst;

It'd be better to keep something like

    case RADEON_HOST_DATA_SWAP_HDW:
	FatalError("Unsupported swap value RADEON_HOST_DATA_SWAP_HDW\n");

so that if somebody makes a change which causes this value to be passed
in, there's an obvious failure (Xorg aborts with the message passed to
FatalError) instead of a subtle one (RADEONCopySwap uses different byte
swapping than intended).